NinjaTrader 7 Mandatory Update

NinjaTrader UpdateThere has been some confusion regarding NinjaTrader’s mandatory update announcement. To simplify the explanation, all NinjaTrader 7 users will need to update to the latest version of NinjaTrader 7 by February 27, 2016. Click here for update instructions. Your existing indicators and customized settings will not be affected by reinstalling, as these files are saved outside of the NinjaTrader program folder.

Also, at this time, you are not required to update to NinjaTrader 8. In fact, NinjaTrader 8 is still in Beta (a non-final stage), and will likely continue to be under development in the months ahead.

The reason why NinjaTrader is forcing users to update is because NinjaTrader 7 versions prior to 7.0.1000.31 do not contain the latest NinjaTrader SSL certificate. Therefore, NinjaTrader will not be able to effectively communicate with its servers, thus breaking functionality. NinjaTrader version 7.0.1000.31 and those released after will contain the latest SSL certificate.

NinjaTrader has stated support for NinjaTrader 7 will continue after NinjaTrader 8 is released.

If you’re still using the really old Windows XP or Windows Server 2003 operating system, you will need to add a certificate on your system manually as described by NinjaTrader here.

Regarding our indicators, after the final NinjaTrader 8 is released, updated indicators for NinjaTrader 8 will be available.

Leave a Reply

All fields are required. Your email address will not be published.